Karl Boeing

Basic AutoSketch Manual

Instruction for students
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Basic AutoSketch Instruction

Screen Layout

In AutoSketch you can create precise 2D (two dimensional) technical drawings.
The screen layout is similar to standard Windows concept.
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You are advised to use only the menu bar for all commands during the first
couple of lessons. The lesson instructions are in text format, which could make it
difficult to pass an assessment if you are not familiar with all the pull-down
menus that are found in the menu bar. However, if you are accustomed with all
the pull-down menus of the menu bar you may use the toolbars.

Toolbars can be turned on or off with a right mouse click in toolbar area and then
from pop-up menu tick (to show) or remove (to turn off) the appropriate toolbar.

Menu bar

The following pictures give you an indication of the headings found in the menu
bar. You can choose some of the menu commands using either the mouse or the
keyboard (eg. File New = Ctrl+N), File Open = Ctrl+O etc.).

If you click on Edit and Draw commands you’ll see on some of the commands a
black arrow ». These commands give you access to pull-down menus.
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File command
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Draw command
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The Window
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many drawing
files are
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select Tile
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from Draw
- Symbol
- Explore

The first step is to get familiar with the AutoSketch screen and all commands found on

the menu bar.

When you start the program (open it) a blank screen will be shown. As with all the

computer programs

Starting a Drawing

AutoSketch is an easy CAD-Program. If you are familiar with technical drawings you
you’ll soon start producing simple CAD-drawings. There are a few basic settings to be
made before you start your drawing.

» First you need to select an appropriate Paper size (eg. A4, A3 etc.) and the drawing
Orientation (Landscape or Portrait)

» The next step is to click on Tools =»Drawing Options (Ctrl Q) and do the following
settings for the time being (we will set up a proto type drawings at a later stage:
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Drawing Options I .
_ Units
Units |I3riu:| i Scale I Drawingl Selectionl File: I

Length = Millimeters
— Length —&ngle N . .
Decimal Precision = change to 1.
iDeglees li
Decimal Precizion: Decimal Precigion: . .
= - -
B || oo | Grid = not yet required
Eractional Precizion: Orientation:
_’ - - -
e =1 | [[5tandard (+Cow) E Scale = select 1:10, 1:20. 1:00 etc.
~Area ~ Scalar Drawings not yet required
ISquare Centimeters ;! Brecisian (Entlty rotation is by default 45°.
Decimal Precision: Jo.o H You can rotate an entity by
{o.01 | selecting the entity and use the + or
v Show Leading Zeros _ key)
Meazurament System: — Decimal Symbal————————— You can set the Draw Parameters -
[ Metric 7| (@) e Plus/Minus Rotation to a different
degree
v Display Units [Length, &ngle, and érea)
ErE There are no further settings at this
efine unitz of measurement X
stage required.

QK i Cancel i

Drawing lines (Select » Draw =sLine)

I Now you can start drawing entities. First use the line

| Fis e cfi‘j .é_ ﬁj'_al command to draw the different line types. The Line Single

' ~ (highlighted) is the active command. The second type is

Line Multiple, the third type is Line Double, the fourth type is Line Tangent, the fifth type
is Line Perpendicular and the sixth type is Line Angle. Explore all different line types and
get familiar with the line commands.

A line is a straight entity between two points with different coordinates. If you click on a
line you'll find all information on the edit toolbar, which should be displayed on the
screen.

Entering points

A line must have a start and an end point. For other entities you may have to select
more points to complete the entity. (an arc requires 3 points or 2 points and a center
point etc.). To move an entity, you must enter a “from” point and a “fo” point.

Snap modes can be accessed from the toolbar or by typing the appropriate letter using
the keyboard.

If the snap mode is not S or G you cannot draw a line. Hit the S-key or G-key (G snaps
on grid point) and then you can select a start-point for an entity (line, arc, circle, polygon
etc.).
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Snap & lock input modes
There are a number of input modes (snhap & lock) you can choose from.

M. Ty v v EYR Qe EL S = Snap mode off
G= GrldeInt input mode

i x[v]° | E = Endpoint input mode J = Jump input mode

— i M = Midpoint input mode N = Nearest input mode
B = Basepoint input mode | = Intersection input mode

U = Unlock P = Perpendicular input mode C = Centerpoint input mode
X = Horizontal Lock T = Tangent input mode Q = Quadrant input mode
Y = Vertical Lock A = Absolute Input R = Relative Input
O = Ortho Lock

L = Normal Lock

Locks gives you control over Horizontal-(x-directions), Vertical-(y-directions) Orthogonal-
movements (both Horiz.- & Vertical-directions). The L Lock let you draw perpendicular
lines to an angle of pre-determined degree. If you don’t want horizontal, vertical or
perpendicular lines type U for Unlock. Unlock is the default setting and is regularly used.

The cursor will always show the Snap and Lock mode that you are presently using. The
cursor shows what snap and lock mode you are currently using (eg. 'su Snap Off and
Unlock or depending on your previous selection®:y End Point and Y Coordinate
(vertical)).

If you can’t do anything, look at your cursor mode and press the S-key to change
to Snap Off and U-key to unlock.

Other Line Commands (straight, curved, polyline fitted curve),

In a broader sense drawing lines include:

v Q @ ':t‘-* B m % . Lines, Arcs, Circles, Poly-lines, Polygones,

A a 4 ' Fitted Curves etc

| There are the different option to draw Arcs. The first is a
3 =T .11 3PointArc, the next a 2 Point Center Arc, then
‘j '\—':l @ g a2 Point Angle Arc, the Elliptical Arc Rectangle and
Elliptical Arc Axes.

These are the option for drawing Circles

| @ {:} C:J @ . Ej: 0 The first Centre & Side (radius); the next

Side Side (diameter); 3 Point circle; etc

Fitted Curves
used for contour lines

Polyli . =
ey L it (J &Y

Avoid using polylines

- Polygons
‘m <:>. @ D D @ g i} Used for drawing all sorts of polygons.

Polyline and Polygons are always one entity. A polygon or line can be exploded into
single entities.
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We want use all line commands at the start and the following explains the most
frequent line commands in greater detail

Drawing a single lines versus Drawing a connected lines

If you select Line Multiple you can draw lines continuously by clicking the next end point
(see Figure 1). The command P Line Single is seldom used

6 To draw separate, unconnected lines To draw a series of connected
Choose the Draw P> Line P> Single lines:
Command. Choose the Draw P Line P>
@/Iultlple i 4 - _ y
® 3 gromman
Figure 1

Lines must heave a start and end point. To start a line (select type Line Single) hit the
“S” and click for a start point (Cursor "zu) give it a direction and length and ‘left’ click
again This terminates the line but you are still in the line command and you can draw
more lines if you want to. The Edit bar shows all information of the line (XY coordinates
of start & end point, length of line and angle of line) until you terminate the command by
a right click. By selecting Line Multiple you can continue to draw more lines. The end
point will be automatically became the start point of the next line lines and more lines
can be drawn until you terminate the command by a ‘right’ click .While drawing the
line(s) watch the Edit bar. If you click on an entity all properties of the entity will be
shown on the Edit bar (lines, circles polygons are all entities). You can also use the
Inquiry command to find the properties of entities).

Coordinates for

Start Point End Paint _
e = kS - 224mm, 1752 mm A 283 mm, 1780 mm F 65 mm A 25.03“ g
Edit bar - | 1
- - Handles \
| ' Line length Line angle |
~ About/Point e e=F W ok
| Figure 2

The Edit bar show you some of the properties of the entity. As shown in Figure 2 the first
field shows the coordinates of the start point and the second field the coordinates of the
end point all relative to the lower left corner of the page. You can change the length and
angle of the line in the edit bar (see Figure 2).

The Handles define the boundaries of the selection set and the About Point is used to
move or rotate the selection set.
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Angular Modes

90° 0° There are two angle modes
- (N) available in AutoSketch.

-~ {NW) (RE)} 1 Standard mode

§ok 270° gge O° totheright anti clockwise as
1307, T . (e)  shown in Figure 3 (a)
- | - and
’ ; (sw) %) 2 Compass mode

180° 0° vertical and angles are in
200 (5) clockwise direction (letters like
N, S, E, W etc can be used as
shown in Figure 3 (b))

(a) (b)
Figure 3

Drawing a two parallel series of connected lines
Choose Draw P Line »> Double

Offset Method
(CENTER)

Offset Method
(LEFT)

Offset Method
(RIGHT)

&

: ® &
Figure 4

It's important to select the correct Offset Method (middle, left, right) because this will
influence your dimensioning. The dimensions are measured from cross point to cross
point. AutoSketch does not select any entities when you cancel this command. It
generates two line entities for each double line drawn.

Drawing a line to arcs and circles (Select » Draw = Circle)

Draw two different circles as shown below. Then draw a line from circle to circle, use the
» Line = Tangent command. Figure 4 (a) and (b) shows how it works. If you click
above the centre lines of the circles, then a tangent is drawn from the curves

Figure 5
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above the centre line Figure 5 (a). If you click below the centre line on the big circle and
above the centre line on the small circle then a tangent is drawn as shown in Figure
5 (b)

How to draw Arcs (Select » Draw => Arc)

There are five ways to draw arcs. The most commons are 2 Point Angle Arc and 2 Point
Centre Arc. Figure 6 below shows the application of the two commands.

Select P 2 Point Angle Arc if you want to draw an arc over an opening as shown in (a). There
are to possibilities to draw an arc

(b) above the chord or
(c) below the chord as shown in Figure 6 (b) and (c).

Option (b) is definitely not what you want. It is important on which line you click first.
Use End point snap to click on the right line, then on the left line. Use right mouse click
to terminate the arc command. The other option to use the 2 Point and Center Arc is
not recommended. However, you should try this option. Select » 2 Point and Center
Arc and click on end point of the right line, then on left line. Nothing can be seen so far.
Change the snap mode to S (hit the S-key) and move the cursor to a position that
satisfies your requirements.

(a) (b)
Figure 6

| ",| =t et The other arc commands are seldom used. However you
o .\:':1 '\?:' — % = should take a crack at those arc commands so that you
know how they work.

Now you should have read enough and be able to start you first Drawing exercise.

Start Exercise 1. This exercise will include basic drawing settings, drawing
different lines and shapes using different snap modes

Drawing Arcs, Circles, Polylines, Rectangles & Fitted Cuves

This portion of the tool bar shows all drawing

P L':J (o) ey [ 1Lt % - commands for lines whether curved or

3 *" straight.
In addition to lines you can draw Arcs, Circles, Polylines, Rectangles and Fitted Curves.
The last icon is a Marker Point
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Polyline

P, « Po ; P A polyline is a series of lines with connected endpoint.
5 C(:/-? They are treated as single entities.

A polyline is useful for drawing entities that have a fixed width, such as a wall in a floor
plan. As you create each polyline segment, text boxes for the segment width and bulge
appear on the edit bar. At this stage we will not use polyline because it is difficult to
master, as a good understanding of polyline editing techniques is needed

Polygons

; : You can draw a variety of different
D (}' E} D D E} Q E}' polygons as shown at the opposite

- toolbar. Polygons can be used to create
solid regions by using the solid fill command. We will scarcely use the polygons
command. AutoSketch can explode polygons, polyline, as well as dimensions, symbols,
to their component entities. This allows you to edit the individual components of an
entity.

Trim command

Y NN AL @ EE

Trimming is a way of refining and finishing a drawing. Trimming allows you to shorten
and lengthen entities to meet at a specific point or break apart and divide entities. Unlike
most of the Edit commands trim requires you to select a command before you specify
the entities you want to trim.

Trim the most often used command. You should now create a customised floating
toolbar with the most used trim commands

Customised toolbar

You can create and edit your own toolbars. Toolbars are automatically saved to disk
when you create or modify them.

Each toolbar is made up of toolsets. Only one button from each

m I A toolset is visible in the toolbar at a time. If you click and hold the

. / m f"’f pointer (small triangle at lower right corner) on that button (see

arrow), the rest of the buttons in the toolset appear.

On the View menu, click Toolbars, or right-click a toolbar,

Click New. The New Toolbar dialog box appears.

Enter the name that you want in this case = trim.

Do not enter a filename in the File text box.

The customise toolbar pop-up menu appears. In the Commands list, select a trim command.

(scroll down the slide bar until you see trim.)

6 Click the following buttons and them drag it to the Sets window and position (1-trim channel,
2-trim corner, 3-trim edge, 4-trim divide).

7 Click Close and you will see the trim floating toolbar on the screen. You can drag the bar

close to any trimming operation on your drawing.

AR WON -

The toolbar can be modified easily. You will modify this toolbar later by adding additional
drawing tools to it.
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Trim Corner
Draw two lines (Figure 7 (a) and select > Trim Corner command. Click on line 1 and line

2 and the two lines will meet at the intersection as shown in Figure 7 (b)

(a)
Figure 7

Trim Edge
Draw again two lines (Figure 8 (a) and select » Trim Edge command. Click on line 1

and then on line 2 and line 2 will extent to line 1 as shown in Figure 8 (b)

line 1

W

(@)

Figure 8

On the Draw menu, click Symbol, Create if you want to update a symbol definition after
editing its components. You must select the component entities first. =
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